Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLW1ocHAtODc1dy05Y3B2

Denial of Service in jquery

Affected versions of jquery use a lowercasing logic on attribute names. When given a boolean attribute with a name that contains uppercase characters, jquery enters into an infinite recursion loop, exceeding the call stack limit, and resulting in a denial of service condition.

Recommendation

Update to version 3.0.0 or later.

Permalink: https://github.com/advisories/GHSA-mhpp-875w-9cpv
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLW1ocHAtODc1dy05Y3B2
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: about 6 years ago
Updated: 10 days ago


CVSS Score: 7.5
CVSS vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Identifiers: GHSA-mhpp-875w-9cpv, CVE-2016-10707
References:

Affected Packages

rubygems:jquery-rails
Versions: = 3.0.0-rc.1
Fixed in: 3.0.0
maven:org.webjars.npm:jquery
Versions: = 3.0.0-rc.1
Fixed in: 3.0.0
nuget:jQuery
Versions: = 3.0.0-rc.1
Fixed in: 3.0.0
npm:jquery
Versions: = 3.0.0-rc.1
Fixed in: 3.0.0