Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWM5Mm0tcnJyYy1xNXdm

safemode gem allows context-dependent attackers to obtain sensitive information via the inspect method

The Safemode gem before 1.2.4 for Ruby, when initialized with a delegate object that is a Rails controller, allows context-dependent attackers to obtain sensitive information via the inspect method.

Permalink: https://github.com/advisories/GHSA-c92m-rrrc-q5wf
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWM5Mm0tcnJyYy1xNXdm
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 6 years ago
Updated: 8 months ago


CVSS Score: 8.1
CVSS vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-c92m-rrrc-q5wf, CVE-2016-3693
References: Repository: https://github.com/svenfuchs/safemode
Blast Radius: 12.7

Affected Packages

rubygems:safemode
Dependent packages: 0
Dependent repositories: 37
Downloads: 842,003 total
Affected Version Ranges: < 1.2.4
Fixed in: 1.2.4
All affected versions: 0.0.2, 1.0.0, 1.0.1, 1.0.2, 1.1.0, 1.2.0, 1.2.1, 1.2.2, 1.2.3
All unaffected versions: 1.2.4, 1.2.5, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.3.5, 1.3.6, 1.3.7, 1.3.8, 1.4.0, 1.5.0