Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWM5ZzYtOTMzNS14Njk3

Improper Input Validation in SocksJS-Node

Incorrect handling of Upgrade header with the value websocket leads in crashing of containers hosting sockjs apps. This affects the package sockjs before 0.3.20.

Permalink: https://github.com/advisories/GHSA-c9g6-9335-x697
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWM5ZzYtOTMzNS14Njk3
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: over 3 years ago
Updated: over 1 year ago


CVSS Score: 5.3
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Identifiers: GHSA-c9g6-9335-x697, CVE-2020-7693
References: Repository: https://github.com/sockjs/sockjs-node
Blast Radius: 34.2

Affected Packages

npm:sockjs
Dependent packages: 754
Dependent repositories: 2,898,020
Downloads: 47,106,549 last month
Affected Version Ranges: < 0.3.20
Fixed in: 0.3.20
All affected versions: 0.0.1, 0.0.2, 0.0.3, 0.0.4, 0.0.5, 0.1.0, 0.1.1, 0.1.2, 0.2.0, 0.2.1, 0.3.0, 0.3.1, 0.3.3, 0.3.4, 0.3.5, 0.3.6, 0.3.7, 0.3.8, 0.3.9, 0.3.10, 0.3.11, 0.3.12, 0.3.13, 0.3.14, 0.3.15, 0.3.16, 0.3.17, 0.3.18, 0.3.19
All unaffected versions: 0.3.20, 0.3.21, 0.3.22, 0.3.23, 0.3.24