An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWN2Zm0teGpjOC1mMnZt

Denial of Service in @commercial/subtext

Version 5.1.1 of @commercial/subtext is vulnerable to Denial of Service. The Content-Encoding HTTP header parser has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. Because hapi rethrows system errors (as opposed to catching expected application errors), the error is thrown all the way up the stack. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services.


Upgrade to version 5.1.2 or later.

Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 3 years ago
Updated: over 1 year ago

Identifiers: GHSA-cvfm-xjc8-f2vm
References: Blast Radius: 0.0

Affected Packages

Dependent packages: 2
Dependent repositories: 2
Downloads: 36 last month
Affected Version Ranges: = 5.1.1
Fixed in: 5.1.2
All affected versions: 5.1.1
All unaffected versions: 5.1.0, 5.1.2, 6.1.3, 7.0.3