An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWNmM3ctZzg2aC0zNXg0

Code Injection vulnerability in CarrierWave::RMagick


CarrierWave::RMagick has a Code Injection vulnerability. Its #manipulate! method inappropriately evals the content of mutation option(:read/:write), allowing attackers to craft a string that can be executed as a Ruby code. If an application developer supplies untrusted inputs to the option, it will lead to remote code execution(RCE).

(But supplying untrusted input to the option itself is dangerous even in absence of this vulnerability, since is prone to DoS vulnerability - attackers can try to consume massive amounts of memory by resizing to a very large dimension)

Proof of Concept

class MyUploader < CarrierWave::Uploader::Base
  include CarrierWave::RMagick
end!({ read: { density: "1 }; p 'Hacked'; {" }}) # => shows "Hacked"


Upgrade to 2.1.1 or 1.3.2.


Stop supplying untrusted input to #manipulate!'s mutation option.


Code Injection Software Attack

For more information

If you have any questions or comments about this advisory:

Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 2 years ago
Updated: 5 months ago

CVSS Score: 7.4
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L

Identifiers: GHSA-cf3w-g86h-35x4, CVE-2021-21305

Affected Packages

Versions: >= 2.0.0, < 2.1.1, < 1.3.2
Fixed in: 2.1.1, 1.3.2