Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWNnNTQtZ3Bnci00cm02

user-readable api tokens in systemd units for JupyterHub

Impact

user API tokens issued to single-user servers are specified in the environment of systemd units, which are accessible to all users.

In particular, the-littlest-jupyterhub is affected, which uses systemdspawner by default.

Patches

Patched in jupyterhub-systemdspawner v0.15

Workarounds

No workaround other than upgrading systemdspawner to 0.15

For more information

If you have any questions or comments about this advisory:

Permalink: https://github.com/advisories/GHSA-cg54-gpgr-4rm6
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWNnNTQtZ3Bnci00cm02
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 3 years ago
Updated: over 1 year ago


CVSS Score: 7.8
CVSS vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N

Identifiers: GHSA-cg54-gpgr-4rm6, CVE-2020-26261
References: Repository: https://github.com/jupyterhub/systemdspawner
Blast Radius: 7.0

Affected Packages

pypi:jupyterhub-systemdspawner
Dependent packages: 0
Dependent repositories: 8
Downloads: 3,842 last month
Affected Version Ranges: < 0.15
Fixed in: 0.15
All affected versions: 0.9.1, 0.9.5, 0.9.6, 0.9.7, 0.9.8, 0.9.9, 0.9.10, 0.9.11, 0.9.12
All unaffected versions: 0.15.0, 0.17.0, 1.0.0, 1.0.1