Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWNxMjctdjd4cC1jMzU2

Buffer Overflow in pycrypto

Heap-based buffer overflow in the ALGnew function in block_templace.c in Python Cryptography Toolkit (aka pycrypto) allows remote attackers to execute arbitrary code as demonstrated by a crafted iv parameter to cryptmsg.py.

Permalink: https://github.com/advisories/GHSA-cq27-v7xp-c356
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWNxMjctdjd4cC1jMzU2
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: over 5 years ago
Updated: over 1 year ago


CVSS Score: 9.8
CVSS vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-cq27-v7xp-c356, CVE-2013-7459
References: Repository: https://github.com/dlitz/pycrypto
Blast Radius: 43.9

Affected Packages

pypi:pycrypto
Dependent packages: 184
Dependent repositories: 30,404
Downloads: 8,258,697 last month
Affected Version Ranges: <= 2.6.1
No known fixed version
All affected versions: 2.0.1, 2.1.0, 2.4.1, 2.6.1