Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWNxNmgtdzNtYy01N2Y0

Information exposure via query strings in URL

Impact

Information exposure via query strings in URL

Patches

We recommend to update to the current version 6.3.4.1. You can get the update to 6.3.4.1 regularly via the Auto-Updater or directly via the download overview.

https://www.shopware.com/en/download/#shopware-6

Workarounds

For older versions of 6.1 and 6.2 the corresponding changes are also available via plugin:

https://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659

For more information

https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-12-2020

Credits

We would like to thank Oliver Herrmann for reporting this issue.

Permalink: https://github.com/advisories/GHSA-cq6h-w3mc-57f4
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWNxNmgtdzNtYy01N2Y0
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Low
Classification: General
Published: over 3 years ago
Updated: over 1 year ago


Identifiers: GHSA-cq6h-w3mc-57f4
References: Repository: https://github.com/shopware/platform
Blast Radius: 0.0

Affected Packages

packagist:shopware/core
Dependent packages: 216
Dependent repositories: 298
Downloads: 2,670,137 total
Affected Version Ranges: <= 6.3.4.0
Fixed in: 6.3.4.1
All affected versions:
All unaffected versions: 6.0.0, 6.1.0, 6.1.1, 6.1.2, 6.1.3, 6.1.4, 6.1.5, 6.1.6, 6.2.0, 6.2.1, 6.2.2, 6.2.3
packagist:shopware/platform
Dependent packages: 6
Dependent repositories: 38
Downloads: 1,166,400 total
Affected Version Ranges: <= 6.3.4.0
Fixed in: 6.3.4.1
All affected versions:
All unaffected versions: 5.3.1, 6.0.0, 6.1.0, 6.1.1, 6.1.2, 6.1.3, 6.1.4, 6.1.5, 6.1.6, 6.2.0, 6.2.1, 6.2.2, 6.2.3