Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWdjMjUtM3ZjNS0yamY5

Sandbox Breakout / Arbitrary Code Execution in sandbox

All versions of sandbox are vulnerable to Sandbox Escape leading to Remote Code Execution. The package fails to restrict access to the main context through this.constructor.constructor . This may allow attackers to execute arbitrary code in the system. Evaluating the payload this.constructor.constructor('return process.env')() prints the contents of process.env.

Recommendation

No fix is currently available. Consider using an alternative package until a fix is made available.

Permalink: https://github.com/advisories/GHSA-gc25-3vc5-2jf9
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWdjMjUtM3ZjNS0yamY5
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: over 3 years ago
Updated: over 1 year ago


Identifiers: GHSA-gc25-3vc5-2jf9
References: Blast Radius: 0.0

Affected Packages

npm:sandbox
Dependent packages: 32
Dependent repositories: 169
Downloads: 1,691 last month
Affected Version Ranges: >= 0.0.0
No known fixed version
All affected versions: 0.7.0, 0.8.0, 0.8.1, 0.8.2, 0.8.3, 0.8.4, 0.8.5, 0.8.6