An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWdqcGgteGY1cS02bWZx

Denial of Service in @hapi/ammo

Versions of @hapi/ammo prior to 3.1.2 or 5.0.1 are vulnerable to Denial of Service. The Range HTTP header parser has a vulnerability which will cause the function to throw a system error if the header is set to an invalid value. Because hapi is not expecting the function to ever throw, the error is thrown all the way up the stack. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services.


Upgrade to version 3.1.2 or 5.0.1.

Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: almost 4 years ago
Updated: over 1 year ago

Identifiers: GHSA-gjph-xf5q-6mfq
References: Blast Radius: 0.0

Affected Packages

Dependent packages: 12
Dependent repositories: 17,185
Downloads: 3,610,663 last month
Affected Version Ranges: >= 4.0.0, < 5.0.1, < 3.1.2
Fixed in: 5.0.1, 3.1.2
All affected versions: 3.1.0, 3.1.1, 4.0.0, 4.0.1, 5.0.0
All unaffected versions: 3.1.2, 5.0.1, 6.0.0, 6.0.1