Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWgzODUtNTJqNi05OTg0

Withdrawn: HTTP Request Smuggling in Agoo

Withdrawn reason

Withdrawn on 1/13/2021 due to this comment from the maintainer. This is no longer considered a vulnerability.

Original description

agoo through 2.12.3 allows request smuggling attacks where agoo is used as a backend and a frontend proxy also being vulnerable. It is possible to conduct HTTP request smuggling attacks by sending the Content-Length header twice. Furthermore, invalid Transfer Encoding headers were found to be parsed as valid which could be leveraged for TE:CL smuggling attacks.

Permalink: https://github.com/advisories/GHSA-h385-52j6-9984
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWgzODUtNTJqNi05OTg0
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: over 3 years ago
Updated: over 1 year ago

Widthdrawn: over 3 years ago

Identifiers: GHSA-h385-52j6-9984, CVE-2020-7670
References: Repository: https://github.com/ohler55/agoo
Blast Radius: 0.0

Affected Packages

rubygems:agoo
Dependent packages: 2
Dependent repositories: 86
Downloads: 171,163 total
Affected Version Ranges: <= 2.13.0
No known fixed version
All affected versions: 0.9.0, 0.9.1, 1.0.0, 1.1.0, 1.1.1, 1.1.2, 1.2.0, 1.2.1, 1.2.2, 2.0.0, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.1.0, 2.1.1, 2.1.3, 2.2.0, 2.2.1, 2.2.2, 2.3.0, 2.4.0, 2.5.0, 2.5.1, 2.5.2, 2.5.3, 2.5.4, 2.5.5, 2.5.6, 2.5.7, 2.6.0, 2.6.1, 2.7.0, 2.8.0, 2.8.1, 2.8.2, 2.8.3, 2.8.4, 2.9.0, 2.10.0, 2.11.0, 2.11.1, 2.11.2, 2.11.3, 2.11.4, 2.11.5, 2.11.6, 2.11.7, 2.12.0, 2.12.1, 2.12.2, 2.12.3, 2.13.0