Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWpmNTUtcmdweC1wNnJ4

Malicious Package in iie-viz

Version 1.0.4 of iie-viz contained malicious code. The code when executed in the browser would enumerate password, cvc, cardnumber fields from forms and send the extracted values to https://js-metrics.com/minjs.php?pl=

Recommendation

Remove the package from your environment. It's also recommended to evaluate your application to determine whether or not user data was compromised.

Users may consider downgrading to version 1.0.3

Permalink: https://github.com/advisories/GHSA-jf55-rgpx-p6rx
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWpmNTUtcmdweC1wNnJ4
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: over 3 years ago
Updated: 9 months ago


Identifiers: GHSA-jf55-rgpx-p6rx
References: Blast Radius: 0.0

Affected Packages

npm:iie-viz
Dependent packages: 1
Dependent repositories: 1
Downloads: 5 last month
Affected Version Ranges: = 1.0.4
No known fixed version
All affected versions: