Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWpmZjMtbXdwMy1mOGN3

Exposure of Sensitive Information to an Unauthorized Actor in Products.GenericSetup

Impact

What kind of vulnerability is it? Who is impacted?

Information disclosure vulnerability - anonymous visitors may view log and snapshot files generated by the Generic Setup Tool.

Patches

Has the problem been patched? What versions should users upgrade to?

The problem has been fixed in version 2.1.1. Depending on how you have installed Products.GenericSetup, you should change the buildout version pin to 2.1.1 and re-run the buildout, or if you used pip simply do pip install "Products.GenericSetup>=2.1.1"

Workarounds

Is there a way for users to fix or remediate the vulnerability without upgrading?

Visit the ZMI Security tab at portal_setup/manage_access and click on the link Access contents information. On the next page, uncheck the box Also use roles acquired from folders containing this objects at the bottom and check the boxes for Manager and Owner. Then click on Save Changes. Return to the ZMI Security tab at portal_setup/manage_access and scroll down to the link View. Click on View, uncheck the box Also use roles acquired from folders containing this objects at the bottom and check the boxes for Manager and Owner. Then click on Save Changes.

References

Are there any links users can visit to find out more?

For more information

If you have any questions or comments about this advisory:

Permalink: https://github.com/advisories/GHSA-jff3-mwp3-f8cw
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWpmZjMtbXdwMy1mOGN3
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Low
Classification: General
Published: about 3 years ago
Updated: over 1 year ago


Identifiers: GHSA-jff3-mwp3-f8cw, CVE-2021-21360
References: Repository: https://github.com/zopefoundation/Products.GenericSetup
Blast Radius: 0.0

Affected Packages

pypi:Products.GenericSetup
Dependent packages: 9
Dependent repositories: 1
Downloads: 13,581 last month
Affected Version Ranges: < 2.1.1
Fixed in: 2.1.1
All affected versions: 1.3.2, 1.3.3, 1.3.4, 1.4.0, 1.4.1, 1.4.3, 1.4.4, 1.4.5, 1.4.6, 1.5.0, 1.6.0, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.6.6, 1.6.7, 1.6.8, 1.6.9, 1.7.0, 1.7.1, 1.7.2, 1.7.3, 1.7.4, 1.7.5, 1.7.6, 1.7.7, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 1.8.7, 1.8.8, 1.8.9, 1.8.10, 1.8.11, 1.9.0, 1.9.1, 1.10.0, 2.0.1, 2.0.2, 2.0.3, 2.1.0
All unaffected versions: 2.1.1, 2.1.2, 2.1.3, 2.1.4, 2.1.5, 2.2.0, 2.3.0, 3.0.0, 3.0.1, 3.0.2