An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWpnNG0tcTZ3OC12cmpw

rgpg Code Injection vulnerability

The self.run_gpg function in lib/rgpg/gpg_helper.rb in the rgpg gem before 0.2.3 for Ruby allows remote attackers to execute arbitrary commands via shell metacharacters in unspecified vectors.

Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 6 years ago
Updated: 6 months ago

Identifiers: GHSA-jg4m-q6w8-vrjp, CVE-2013-4203
References: Repository:
Blast Radius: 1.0

Affected Packages

Dependent packages: 0
Dependent repositories: 0
Downloads: 31,399 total
Affected Version Ranges: < 0.2.3
Fixed in: 0.2.3
All affected versions: 0.0.0, 0.1.0, 0.2.0, 0.2.1, 0.2.2
All unaffected versions: 0.2.3, 0.2.4, 0.3.0, 0.4.0