Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWpoajYtNW1oNi00cHZm

Denial-of-Service within Docker container

Impact

If you run teler inside a Docker container and encounter errors.Exit function, it will cause denial-of-service (SIGSEGV) because it doesn't get process ID and process group ID of teler properly to kills.

Specific Go Packages Affected

ktbs.dev/teler/pkg/errors

Patches

Upgrade to the >= 0.0.1 version.

Workarounds

N/A

References

For more information

If you have any questions or comments about this advisory:

Permalink: https://github.com/advisories/GHSA-jhj6-5mh6-4pvf
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWpoajYtNW1oNi00cHZm
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 3 years ago
Updated: 9 months ago


CVSS Score: 5.9
CVSS vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Identifiers: GHSA-jhj6-5mh6-4pvf, CVE-2020-26213
References: Repository: https://github.com/kitabisa/teler
Blast Radius: 1.0

Affected Packages

go:ktbs.dev/teler
Dependent packages: 0
Dependent repositories: 0
Downloads:
Affected Version Ranges: < 0.0.1
Fixed in: 0.0.1
All affected versions:
All unaffected versions: 0.0.1, 0.0.2, 0.0.3, 0.0.4, 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.1.0, 1.1.1, 1.2.0, 1.2.1, 1.2.2