Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWpwY20tNDQ4NS02OXA3

Sensitive information disclosure via log in com.bmuschko:gradle-vagrant-plugin

Impact

The com.bmuschko:gradle-vagrant-plugin Gradle plugin contains an information disclosure vulnerability due to the logging of the system environment variables.

When this Gradle plugin is executed in public CI/CD, this can lead to sensitive credentials being exposed to malicious actors.

Patches

Fixed in version 3.0.0

References

For more information

If you have any questions or comments about this advisory:

Permalink: https://github.com/advisories/GHSA-jpcm-4485-69p7
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWpwY20tNDQ4NS02OXA3
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 3 years ago
Updated: over 1 year ago


CVSS Score: 7.4
CVSS vector: CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N

Identifiers: GHSA-jpcm-4485-69p7, CVE-2021-21361
References: Repository: https://github.com/JLLeitschuh/security-research
Blast Radius: 0.0

Affected Packages

maven:com.bmuschko:gradle-vagrant-plugin
Dependent packages: 0
Dependent repositories: 1
Downloads:
Affected Version Ranges: >= 0.6, < 3.0.0
Fixed in: 3.0.0
All affected versions: 2.2.1
All unaffected versions: 3.0.0