An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLXA0OTMtNjM1cS1yNmdy

Remote code execution via the `pretty` option.


If a remote attacker was able to control the pretty option of the pug compiler, e.g. if you spread a user provided object such as the query parameters of a request into the pug template inputs, it was possible for them to achieve remote code execution on the node.js backend.


Upgrade to [email protected] or [email protected] or [email protected], which correctly sanitise the parameter.


If there is no way for un-trusted input to be passed to pug as the pretty option, e.g. if you compile templates in advance before applying user input to them, you do not need to upgrade.


Original report:

For more information

If you believe you have found other vulnerabilities, please DO NOT open an issue. Instead, you can follow the instructions in our Security Policy

Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 2 years ago
Updated: 10 months ago

CVSS Score: 6.8
CVSS vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:N

Identifiers: GHSA-p493-635q-r6gr, CVE-2021-21353

Affected Packages

Versions: >= 3.0.0, < 3.0.2, < 2.0.3
Fixed in: 3.0.2, 2.0.3
Versions: < 3.0.1
Fixed in: 3.0.1