Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLXE0MnEtNTIzZy0zZnd2

Cross-Site Request Forgery

This affects the package com.softwaremill.akka-http-session:core_2.13 before 0.5.11; the package com.softwaremill.akka-http-session:core_2.12 before 0.5.11; the package com.softwaremill.akka-http-session:core_2.11 before 0.5.11. For older versions, endpoints protected by randomTokenCsrfProtection could be bypassed with an empty X-XSRF-TOKEN header and an empty XSRF-TOKEN cookie.

Permalink: https://github.com/advisories/GHSA-q42q-523g-3fwv
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLXE0MnEtNTIzZy0zZnd2
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: over 2 years ago
Updated: over 1 year ago


CVSS Score: 8.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Identifiers: GHSA-q42q-523g-3fwv, CVE-2020-7780
References: Repository: https://github.com/softwaremill/akka-http-session
Blast Radius: 4.2

Affected Packages

maven:com.softwaremill.akka-http-session:core_2.11
Dependent packages: 2
Dependent repositories: 3
Downloads:
Affected Version Ranges: < 0.5.11
Fixed in: 0.5.11
All affected versions: 0.2.0, 0.2.1, 0.2.2, 0.2.3, 0.2.4, 0.2.5, 0.2.6, 0.2.7, 0.3.0, 0.4.0, 0.5.0, 0.5.1, 0.5.2, 0.5.3, 0.5.4, 0.5.5, 0.5.6, 0.5.7, 0.5.8, 0.5.9, 0.5.10
All unaffected versions: 0.5.11
maven:com.softwaremill.akka-http-session:core_2.12
Dependent packages: 3
Dependent repositories: 1
Downloads:
Affected Version Ranges: < 0.5.11
Fixed in: 0.5.11
All affected versions:
All unaffected versions: 0.7.0, 0.7.1
maven:com.softwaremill.akka-http-session:core_2.13
Dependent packages: 3
Dependent repositories: 1
Downloads:
Affected Version Ranges: < 0.5.11
Fixed in: 0.5.11
All affected versions:
All unaffected versions: 0.7.0, 0.7.1