Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLXEzdzktZzc0cS12cDVm

Denial of Service in express-fileupload

Versions of express-fileupload prior to 1.1.6-alpha.6 are vulnerable to Denial of Service. The package causes server responses to be delayed (up to 30s in internal testing) if the request contains a large filename of . characters.

Recommendation

Upgrade to version 1.1.6-alpha.6 or later.

Permalink: https://github.com/advisories/GHSA-q3w9-g74q-vp5f
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLXEzdzktZzc0cS12cDVm
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Low
Classification: General
Published: over 3 years ago
Updated: over 1 year ago


Identifiers: GHSA-q3w9-g74q-vp5f
References: Blast Radius: 0.0

Affected Packages

npm:express-fileupload
Dependent packages: 796
Dependent repositories: 26,468
Downloads: 1,400,369 last month
Affected Version Ranges: <= 1.0.0-alpha.1, <= 1.1.1-alpha.3, <= 1.1.2-alpha.1, <= 1.1.3-alpha.2, < 1.1.6-alpha.6
Fixed in: 1.1.6-alpha.6, 1.1.6-alpha.6, 1.1.6-alpha.6, 1.1.6-alpha.6, 1.1.6-alpha.6
All affected versions: 0.0.1, 0.0.2, 0.0.3, 0.0.4, 0.0.5, 0.0.6, 0.0.7, 0.1.0, 0.1.1, 0.1.2, 0.1.3, 0.1.4, 0.2.0, 0.3.0, 0.4.0, 1.0.0, 1.0.0-alpha.1, 1.1.1-alpha.1, 1.1.1-alpha.2, 1.1.1-alpha.3, 1.1.2-alpha.1, 1.1.3-alpha.1, 1.1.3-alpha.2, 1.1.4, 1.1.5, 1.1.6-alpha.1, 1.1.6-alpha.2, 1.1.6-alpha.3, 1.1.6-alpha.4, 1.1.6-alpha.5
All unaffected versions: 1.1.6, 1.1.8, 1.1.9, 1.1.10, 1.2.0, 1.2.1, 1.3.0, 1.3.1, 1.4.0, 1.4.1, 1.4.2, 1.4.3, 1.5.0