Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLXY1MjUtYzNnNS1jZzlw

Unsafe Deserialization that can Result in Code Execution

JMS Client for RabbitMQ 1.x before 1.15.2 and 2.x before 2.2.0 is vulnerable to unsafe deserialization that can result in code execution via crafted StreamMessage data.

Permalink: https://github.com/advisories/GHSA-v525-c3g5-cg9p
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLXY1MjUtYzNnNS1jZzlw
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: about 2 years ago
Updated: about 1 year ago


Identifiers: GHSA-v525-c3g5-cg9p, CVE-2020-36282
References:

Affected Packages

maven:com.rabbitmq.jms:rabbitmq-jms
Versions: >= 1.0, < 1.15.2, >= 2.0, < 2.2.0
Fixed in: 1.15.2, 2.2.0