Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLXZtN2otNHJqNi1tdzJw

Malicious Package in ember_cli_babe

Version 6.16.0 of ember_cli_babe contains malicious code as a preinstall script. The package is malware designed to take advantage of users making a mistake when typing the name of a module to install. When installed, the package downloads a file from a remote server, executes it and opens a backdoor.

Recommendation

Any computer that has this package installed or running should be considered fully compromised. All secrets and keys stored on that computer should be rotated immediately from a different computer.

The package should be removed, but as full control of the computer may have been given to an outside entity, there is no guarantee that removing the package will remove all malicious software resulting from installing it.

Permalink: https://github.com/advisories/GHSA-vm7j-4rj6-mw2p
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLXZtN2otNHJqNi1tdzJw
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: almost 4 years ago
Updated: over 1 year ago


CVSS Score: 9.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-vm7j-4rj6-mw2p
References: Blast Radius: 6.8

Affected Packages

npm:ember_cli_babe
Dependent packages: 1
Dependent repositories: 5
Downloads: 10 last month
Affected Version Ranges: >= 0.0.0
No known fixed version
All affected versions: