Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLXZyYzctNmc4dy1qaDU2

Improper Input Validation in xdLocalStorage

An issue was discovered in xdLocalStorage through 2.0.5. The receiveMessage() function in xdLocalStoragePostMessageApi.js does not implement any validation of the origin of web messages. Remote attackers who can entice a user to load a malicious site can exploit this issue to impact the confidentiality and integrity of data in the local storage of the vulnerable site via malicious web messages.

Permalink: https://github.com/advisories/GHSA-vrc7-6g8w-jh56
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLXZyYzctNmc4dy1qaDU2
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 2 years ago
Updated: over 1 year ago


CVSS Score: 7.1
CVSS vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N

Identifiers: GHSA-vrc7-6g8w-jh56, CVE-2015-9544
References: Repository: https://github.com/ofirdagan/cross-domain-local-storage
Blast Radius: 5.0

Affected Packages

npm:xdLocalStorage
Dependent packages: 1
Dependent repositories: 5
Downloads: 672 last month
Affected Version Ranges: <= 2.0.5
No known fixed version
All affected versions: 2.0.3, 2.0.4, 2.0.5