Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLXc0d3EtcnZtcS03N3g3

Cross-site scripting in anchorme

All versions of package anchorme are vulnerable to Cross-site Scripting (XSS) via the main functionality.

Permalink: https://github.com/advisories/GHSA-w4wq-rvmq-77x7
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLXc0d3EtcnZtcS03N3g3
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: almost 3 years ago
Updated: over 1 year ago


CVSS Score: 5.4
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N

Identifiers: GHSA-w4wq-rvmq-77x7, CVE-2021-23411
References: Repository: https://github.com/alexcorvi/anchorme.js
Blast Radius: 14.3

Affected Packages

npm:anchorme
Dependent packages: 69
Dependent repositories: 442
Downloads: 174,166 last month
Affected Version Ranges: <= 2.1.2
No known fixed version
All affected versions: 0.7.0, 0.7.1, 0.7.2, 0.8.0, 0.8.1, 0.8.2, 0.8.3, 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.1.0, 1.1.1, 1.1.2, 2.0.0, 2.1.0, 2.1.1, 2.1.2