Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLXc0dnAtM21xNy03djgy

Cross-Site Scripting in lazysizes

Versions of lazysizes prior to 5.2.1-rc1 are vulnerable to Cross-Site Scripting. The video-embed plugin fails to sanitize the following attributes: data-vimeo, data-vimeoparams, data-youtube and data-ytparams. This allows attackers to execute arbitrary JavaScript in a victim's browser if the attacker has control over the vulnerable attributes.

Recommendation

Upgrade to version 5.2.1-rc1 or later.

Permalink: https://github.com/advisories/GHSA-w4vp-3mq7-7v82
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLXc0dnAtM21xNy03djgy
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 3 years ago
Updated: over 1 year ago


Identifiers: GHSA-w4vp-3mq7-7v82
References: Repository: https://github.com/aFarkas/lazysizes
Blast Radius: 0.0

Affected Packages

npm:lazysizes
Dependent packages: 225
Dependent repositories: 5,283
Downloads: 978,666 last month
Affected Version Ranges: <= 5.2.1-rc0
Fixed in: 5.2.1-rc1
All affected versions: 0.4.0, 0.5.0, 0.5.1, 0.5.2, 0.5.3, 0.6.0, 0.6.1, 0.7.1, 0.7.2, 0.8.0, 0.8.1, 0.9.0, 1.0.0, 1.0.1, 1.1.0, 1.1.2, 1.1.3, 1.1.4, 1.1.5, 1.2.0, 1.2.1, 1.2.2, 1.3.0, 1.3.1, 1.3.2, 1.4.0, 1.5.0, 2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.7, 3.0.0, 4.0.0, 4.0.1, 4.0.2, 4.0.3, 4.0.4, 4.1.0, 4.1.1, 4.1.2, 4.1.3, 4.1.4, 4.1.5, 4.1.6, 4.1.7, 4.1.8, 5.0.0, 5.1.0, 5.1.1, 5.1.2, 5.2.0
All unaffected versions: 5.2.1, 5.2.2, 5.3.0, 5.3.1, 5.3.2