Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLXhyN3ItODhxdi1xN2ht

Out of bounds write in serde_cbor

Affected versions of this crate did not properly check if semantic tags were nested excessively during deserialization. This allows an attacker to craft small (< 1 kB) CBOR documents that cause a stack overflow. The flaw was corrected by limiting the allowed number of nested tags.

Permalink: https://github.com/advisories/GHSA-xr7r-88qv-q7hm
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLXhyN3ItODhxdi1xN2ht
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 2 years ago
Updated: 10 months ago


CVSS Score: 7.5
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Identifiers: GHSA-xr7r-88qv-q7hm, CVE-2019-25001
References: Repository: https://github.com/pyfisch/cbor
Blast Radius: 28.0

Affected Packages

cargo:serde_cbor
Dependent packages: 389
Dependent repositories: 5,355
Downloads: 28,785,235 total
Affected Version Ranges: < 0.10.2
Fixed in: 0.10.2
All affected versions: 0.1.0, 0.2.0, 0.2.1, 0.3.0, 0.3.1, 0.3.2, 0.3.3, 0.4.0, 0.5.0, 0.5.1, 0.5.2, 0.6.0, 0.6.1, 0.8.0, 0.8.1, 0.8.2, 0.9.0, 0.10.0, 0.10.1
All unaffected versions: 0.10.2, 0.11.0, 0.11.1, 0.11.2