Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLXhyOGgtNTN4ci1qaGNt

Path Traversal in marked-tree

This affects all versions up to and including version 0.8.1 of package marked-tree. There is no path sanitization in the path provided at fs.readFile in index.js.

Permalink: https://github.com/advisories/GHSA-xr8h-53xr-jhcm
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLXhyOGgtNTN4ci1qaGNt
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: about 3 years ago
Updated: over 1 year ago


CVSS Score: 7.5
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Identifiers: GHSA-xr8h-53xr-jhcm, CVE-2020-7682
References: Blast Radius: 0.0

Affected Packages

npm:marked-tree
Dependent packages: 1
Dependent repositories: 1
Downloads: 33 last month
Affected Version Ranges: <= 0.8.1
No known fixed version
All affected versions: 0.7.0, 0.7.1, 0.7.2, 0.7.3, 0.7.4, 0.7.5, 0.7.6, 0.8.0, 0.8.1