Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

packagist grumpydictator/firefly-iii Security Advisories

Loading...
Moderate
GSA_kwCzR0hTQS00Z200LWM0bWgtNHA3d84AA9I2
Firefly III has a MFA bypass in oauth flow
Ecosystems: packagist
Packages: grumpydictator/firefly-iii
Source: GitHub Advisory Database
Blast Radius: 4.1
Published: 26 days ago
Moderate
GSA_kwCzR0hTQS0yOXc2LWM1MmctbThqY84AA49-
C5 Firefly III CSV Injection.
Ecosystems: packagist
Packages: grumpydictator/firefly-iii
Source: GitHub Advisory Database
Blast Radius: 2.8
Published: 5 months ago
Moderate
GSA_kwCzR0hTQS12d3YyLTl3Y2otNjR2eM4AA4M1
Firefly III allows webhooks HTML Injection.
Ecosystems: packagist
Packages: grumpydictator/firefly-iii
Source: GitHub Advisory Database
Blast Radius: 4.5
Published: 6 months ago
Moderate
GSA_kwCzR0hTQS1oN3Z2LTQ2cDUtcHJtaM4AAyjs
Firefly III insufficiently expires sessions
Ecosystems: packagist
Packages: grumpydictator/firefly-iii
Source: GitHub Advisory Database
Blast Radius: 2.9
Published: over 1 year ago
Moderate
GSA_kwCzR0hTQS1td3h3LWh4dnAtNHIycs4AAyfe
Firefly III vulnerable to improper input validation
Ecosystems: packagist
Packages: grumpydictator/firefly-iii
Source: GitHub Advisory Database
Blast Radius: 4.1
Published: over 1 year ago
Moderate
GSA_kwCzR0hTQS03bWM0LWpwNGYtdjJqMs4AAw-x
Improper Authorization in grumpydictator/firefly-iii
Ecosystems: packagist
Packages: grumpydictator/firefly-iii
Source: GitHub Advisory Database
Blast Radius: 4.5
Published: over 1 year ago
High
GSA_kwCzR0hTQS01Z3E3LTgyNnctODI4Ms4AAqWX
Unrestricted File Upload vulnerability in Firefly III
Ecosystems: packagist
Packages: grumpydictator/firefly-iii
Source: GitHub Advisory Database
Blast Radius: 6.2
Published: about 2 years ago
Moderate
GSA_kwCzR0hTQS01aHB3LXZjajItcHJ3Z84AAhVZ
Firefly III vulnerable to stored XSS
Ecosystems: packagist
Packages: grumpydictator/firefly-iii
Source: GitHub Advisory Database
Blast Radius: 3.8
Published: about 2 years ago
Moderate
GSA_kwCzR0hTQS1tcmMyLWg3cTItcHA5N84AAhVY
Firefly III vulnerable to reflected cross-site scripting
Ecosystems: packagist
Packages: grumpydictator/firefly-iii
Source: GitHub Advisory Database
Blast Radius: 3.8
Published: about 2 years ago
Moderate
GSA_kwCzR0hTQS1wY3hxLTI4ZjYtbTNmbc4AAhVb
Firefly III vulnerable to image-based stored XSS
Ecosystems: packagist
Packages: grumpydictator/firefly-iii
Source: GitHub Advisory Database
Blast Radius: 3.8
Published: about 2 years ago
Moderate
GSA_kwCzR0hTQS05eG14LXJqN2otZnY5cc4AAhVh
Firefly III vulnerable to stored XSS
Ecosystems: packagist
Packages: grumpydictator/firefly-iii
Source: GitHub Advisory Database
Blast Radius: 3.8
Published: about 2 years ago
Moderate
GSA_kwCzR0hTQS1oamhwLWh3ZmotaHdmM80ZNQ
Cross Site Request Forgery in firefly-iii
Ecosystems: packagist
Packages: grumpydictator/firefly-iii
Source: GitHub Advisory Database
Blast Radius: 3.0
Published: over 2 years ago
Moderate
GSA_kwCzR0hTQS1nNnZxLXdjOHctNGc2Oc0Y3Q
firefly-iii is vulnerable to Cross-Site Request Forgery (CSRF)
Ecosystems: packagist
Packages: grumpydictator/firefly-iii
Source: GitHub Advisory Database
Blast Radius: 3.0
Published: over 2 years ago
Moderate
GSA_kwCzR0hTQS1xMmN2LTk0eG0tcXZnNM0XNA
firefly-iii is vulnerable to Cross-Site Request Forgery (CSRF)
Ecosystems: packagist
Packages: grumpydictator/firefly-iii
Source: GitHub Advisory Database
Blast Radius: 3.8
Published: over 2 years ago
Moderate
GSA_kwCzR0hTQS1wZmo3LXczNzMtZ3FjaM0WwQ
Cross-Site Request Forgery in firefly-iii
Ecosystems: packagist
Packages: grumpydictator/firefly-iii
Source: GitHub Advisory Database
Blast Radius: 4.5
Published: over 2 years ago
Low
GSA_kwCzR0hTQS1ycWdwLWNjcGgtNXc2Nc0WwA
Cross-Site Request Forgery in firefly-iii
Ecosystems: packagist
Packages: grumpydictator/firefly-iii
Source: GitHub Advisory Database
Blast Radius: 2.4
Published: over 2 years ago
Moderate
GSA_kwCzR0hTQS01ZnZ4LTVwMnItNG12cM0WoQ
Open Redirect in firefly-iii
Ecosystems: packagist
Packages: grumpydictator/firefly-iii
Source: GitHub Advisory Database
Blast Radius: 3.5
Published: over 2 years ago
Moderate
GSA_kwCzR0hTQS0zNTZyLTc3cTgtZjY0Zs0WAw
Cross-Site Request Forgery in firefly-iii
Ecosystems: packagist
Packages: grumpydictator/firefly-iii
Source: GitHub Advisory Database
Blast Radius: 3.0
Published: almost 3 years ago
Low
MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWpqY3gtOTk5bS0zNWhj
Improper Input Validation in Firefly III
Ecosystems: packagist
Packages: grumpydictator/firefly-iii
Source: GitHub Advisory Database
Blast Radius: 2.3
Published: almost 3 years ago
Moderate
MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLXhwNXEtNzdtaC02aG0y
firefly-iii is vulnerable to Cross-Site Request Forgery (CSRF)
Ecosystems: packagist
Packages: grumpydictator/firefly-iii
Source: GitHub Advisory Database
Blast Radius: 4.5
Published: almost 3 years ago
Moderate
MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWM2NzYtbWN3My1xZzU1
firefly-iii is vulnerable to Cross-Site Request Forgery (CSRF)
Ecosystems: packagist
Packages: grumpydictator/firefly-iii
Source: GitHub Advisory Database
Blast Radius: 4.5
Published: almost 3 years ago
Moderate
MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLWdwNnctY2Nxdi1wN3Fy
firefly-iii is vulnerable to Cross-Site Request Forgery (CSRF)
Ecosystems: packagist
Packages: grumpydictator/firefly-iii
Source: GitHub Advisory Database
Blast Radius: 3.0
Published: almost 3 years ago
Moderate
MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTU2Y3gtd2Y0Ny1oeDd3
No Restriction of Excessive Authentication Attempts in Firefly III
Ecosystems: packagist
Packages: grumpydictator/firefly-iii
Source: GitHub Advisory Database
Blast Radius: 3.7
Published: almost 3 years ago
Statistics
Advisories: 19,486
Packages: 8,600
Repositories: 1
Ecosystems: 12
Filter by Package
moodle/moodle 342 magento/community-edition 204 typo3/cms 174 pimcore/pimcore 117 dolibarr/dolibarr 111 typo3/cms-core 106 phpmyadmin/phpmyadmin 92 microweber/microweber 91 drupal/core 91 silverstripe/framework 83 drupal/drupal 76 thorsten/phpmyfaq 70 symfony/symfony 64 librenms/librenms 54 concrete5/concrete5 52 shopware/platform 48 baserproject/basercms 43 showdoc/showdoc 40 craftcms/cms 40 intelliants/subrion 39 froxlor/froxlor 37 nilsteampassnet/teampass 37 shopware/core 36 zendframework/zendframework1 34 snipe/snipe-it 33 shopware/shopware 30 mautic/core 30 getgrav/grav 29 centreon/centreon 27 prestashop/prestashop 26 magento/core 24 mediawiki/core 24 remdex/livehelperchat 23 pocketmine/pocketmine-mp 23 zendframework/zendframework 23 grumpydictator/firefly-iii 23 simplesamlphp/simplesamlphp 23 getkirby/cms 22 contao/core-bundle 21 tribalsystems/zenario 20 laravel/framework 19 contao/contao 18 forkcms/forkcms 18 cockpit-hq/cockpit 18 cakephp/cakephp 17 francoisjacquet/rosariosis 17 genix/cms 17 ezsystems/ezpublish-kernel 17 topthink/framework 17 symfony/security 17 opencart/opencart 16 yetiforce/yetiforce-crm 16 ec-cube/ec-cube 15 openmage/magento-lts 15 october/system 15 smarty/smarty 15 phpmailer/phpmailer 14 typo3/cms-backend 14 symfony/security-http 14 silverstripe/cms 14 lavalite/cms 13 bolt/bolt 13 impresscms/impresscms 13 codeigniter4/framework 13 elefant/cms 13 studio-42/elfinder 12 phpmyfaq/phpmyfaq 12 dompdf/dompdf 12 phpbb/phpbb 12 tinymce/tinymce 11 TinyMCE 11 pimcore/admin-ui-classic-bundle 11 sylius/sylius 11 symfony/http-foundation 11 tinymce 11 wwbn/avideo 11 feehi/feehicms 11 ezsystems/ezplatform-kernel 11 feehi/cms 11 wallabag/wallabag 10 ssddanbrown/bookstack 10 nukeviet/nukeviet 10 admidio/admidio 10 pagekit/pagekit 10 yiisoft/yii2 10 ezsystems/ezpublish-legacy 10 kevinpapst/kimai2 9 concrete5/core 9 contao/core 9 october/october 9 alextselegidis/easyappointments 9 funadmin/funadmin 9 statamic/cms 8 october/cms 8 silverstripe/admin 8 croogo/croogo 8 pimcore/customer-management-framework-bundle 8 facturascripts/facturascripts 8 composer/composer 8 sulu/sulu 8 codiad/codiad 8 silverstripe/graphql 8 gilacms/gila 8 pterodactyl/panel 7 mantisbt/mantisbt 7 wpglobus/wpglobus 7 flarum/core 7 ezsystems/ezplatform-admin-ui 7 passbolt/passbolt_api 7 october/backend 7 symfony/http-kernel 7 zoujingli/thinkadmin 6 vrana/adminer 6 yourls/yourls 6 directmailteam/direct-mail 6 nystudio107/craft-seomatic 6 guzzlehttp/guzzle 6 dweeves/magmi 6 phpseclib/phpseclib 6 oro/platform 6 in2code/femanager 6 backdrop/backdrop 6 gleez/cms 6 bagisto/bagisto 6 yiisoft/yii2-dev 6 elgg/elgg 5 neos/flow 5 symfony/security-core 5 woocommerce/woocommerce 5 neos/neos 5 cachethq/cachet 5 illuminate/database 5 typo3/cms-install 5 automad/automad 5 phpxmlrpc/phpxmlrpc 5 simplesamlphp/saml2 5 silverstripe/assets 5 ibexa/core 5 bottelet/flarepoint 5 anchorcms/anchor-cms 5 phpservermon/phpservermon 5 billz/raspap-webgui 5 gugoan/economizzer 5 twig/twig 5 codeigniter/framework 5 typo3/flow 5 thinkcmf/thinkcmf 5 pear/archive_tar 5 sylius/resource-bundle 4 spatie/browsershot 4 typo3/html-sanitizer 4 oro/commerce 4 notrinos/notrinos-erp 4 magento/product-community-edition 4 idno/known 4 wintercms/winter 4 shopxo/shopxo 4 bref/bref 4 kimai/kimai 4 appwrite/server-ce 4 symfony/security-bundle 4 shopware/storefront 4 friendsofsymfony/user-bundle 4 ezsystems/ezplatform 4 pyrocms/pyrocms 4 evolutioncms/evolution 4 codeigniter4/shield 4 zendframework/zendopenid 4 wp-premium/gravityforms 4 modx/revolution 4 bytefury/crater 4 typo3/cms-frontend 4 adodb/adodb-php 4 joomla/framework 3 pixelfed/pixelfed 3 zendframework/zend-diactoros 3 swiftmailer/swiftmailer 3 limesurvey/limesurvey 3 amphp/http-client 3 symfony/form 3 processwire/processwire 3 enhavo/enhavo-app 3 illuminate/auth 3 verot/class.upload.php 3 froala/wysiwyg-editor 3 zendframework/zend-http 3 ckeditor4 3 enshrined/svg-sanitize 3 prestashop/productcomments 3 qcubed/qcubed 3 django-tinymce 3 yiisoft/yii 3 tecnickcom/tcpdf 3 artesaos/seotools 3 privatebin/privatebin 3 quickapps/cms 3 doctrine/orm 3 rudloff/alltube 3 bbpress/bbpress 3 verbb/comments 3